Checking out PureOS and Librem 14

Continuing the discussion from `deck`, Librem 14 laptop:

The Librem 14 laptop I received contains the PureOS operating system. I’ve never used PureOS before, my standard is Fedora Linux, so I’m going to try it out and document my impressions here.

The laptop’s display is 1920x1080 (16:9). With the default settings, everything is a bit small for me.

Here I was going to upload a screenshot showing the web browser text, but Gnome Web doesn’t work with the upload feature in Discourse.

Great start. :rofl:

The image from before, using Gnome Web:

And today, after setting Firefox up:

The text is very small for everything, so now I’ve got to figure out where to make changes: per app, or using Gnome Tweaks, etc.

:thinking:

Notable only because I’ve never had to install it before: tree

Which was easy enough, sudo apt install tree.

I love that command. :slight_smile:

Using PureOS is fine. I was documenting this in case I had trouble moving between Fedora and PureOS, or really dnf versus apt.

My fog computing is fairly standardized, so there aren’t any surprises moving between systems. I believe Flatpak has the most to do with that.

Never had a reason to use zstd directly before, but was able to sudo apt install zstd. :slight_smile:

Today I thought I might try setting up a development container, and launched GNOME Boxes, a virtual machine GUI. I saw:

As I was following the instruction to use the software correctly I thought two things:

  1. That’s a great default! You don’t want any user eating up all your computer’s resources by launching VMs, and
  2. I bet there are some that hate this setup; it makes a user have to think about how computers work!

I appreciate it. :slight_smile:

1 Like

First real issue I’ve run into: typing in Japanese.

I found a solution at Japanese Hiragana Input - PureOS - Purism community.

apt install ibus-mozc

After a restart I was able to type my name: マイキ.

That’s important, since it’s my login to Wikipedia. :slight_smile:

I’m not sure why the existing Japanese locales didn’t work for me; they were either English keyboard layouts, or hiragana characters on the keyboard layout, which isn’t helpful as I can’t see the characters on my keyboard… instead mozc acts like anthy in the past: a “romanji” input method; so I type “maiki” and tab through to the correct rendering.

Romanji isn’t great for Japanese learners, as it creates an additional abstraction to get past… but works really well when you use laptops with English keyboards. :upside_down_face: